null Rancher 2.3.3发布!默认支持K8S 1.16 - K码农

2019年11月28日,Rancher Labs发布了Rancher全新版本2.3.3,该版本默认支持Kubernetes1.16,此外还带来了其他功能与优化。

目前,Rancher的Latest和Stable版本信息如下:

新功能亮点和优化

默认支持Kubernetes 1.16

  • Kubernetes 1.16现在是默认版本。由于Kubernetes 1.16版本中不赞成使用不同的API,因此在使用Kubernetes 1.16之前请先检查您的工作负载和应用程序是否符合1.16中的API要求。

vmware vSphere驱动程序增强

  • 设置VM时可以使用受支持的OS操作系统

  • 能够从数据中心模板、vSphere内容库创建模板或克隆现有虚拟机

  • 能够分配标签和自定义属性

  • 能够将数据存储群集用作数据存储

  • UI增加vCenter面板

管理员可以控制所有节点模板

  • 管理员现在可以在Rancher中维护所有节点模板。当节点模板所有者不再使用Rancher时,管理员可以管理由他们创建的节点模板,因此可以继续更新和维护集群。

能够将现有集群配置导出到RKE模板中

  • 如果已经使用RKE部署集群,则现在可以将集群导出为模板,并开始使用RKE模板管理对集群的更新。

BUG修复

  • 修复了kube-proxy无法支持IPVS的问题[#13769 ]

  • 修复了无法为RKE启动的集群将extra_envs、extra_volumes或extra_volume_mounts传递到Nginx ingress controller的问题[#16868 ]

  • 修复了自定义架构下的搜索过滤器不能用于openldap [#18630 ]的问题

  • 修复了由Rancher创建的仓库密钥中缺少auth字段的问题[#19032 ]

  • 解决了从catalog修改应用程序时,answers.yaml和以yaml进行编辑不同步的问题[#20087 ]

  • 修复了导入的RKE集群无法在项目级别使用容器级别的安全管控功能问题[ #21039 ]

  • 修复了节点provisioning不遵守NO_PROXY环境变量[#21674 ]的问题

  • 修复了启用Amazon和AWS云提供商时代理和主机名会出现一些问题的问题[#22849 ]

  • 允许用户隐藏永远不会达到NodeReady状态的节点。某些集成要求创建一个不会运行kubelet的“虚拟”节点。[#23394 ]

若您想了解与上述各个issue相关的详细信息,请至Rancher GitHub issue界面输入issue编号进行查询:

https://github.com/rancher/rancher/issues

下载及升级

您可以到Rancher Github主页阅读完整的Rancher 2.3.3 Release Note、下载最新使用版本或了解更多与升级回滚有关的注意事项。

Github链接:

https://github.com/rancher/rancher/releases

想要详细了解Rancher 2.3的新功能吗?欢迎参加我们下周三的在线培训《Rancher2.3集群模板及新特性》噢,报名及观看链接:

http://www.itdks.com/Home/Live/detail?id=28601